Atom Packages Directory

a package directory for a text editor of the 21st Century

Terminate Syntax

Install with:
    apm install terminate-syntax
  

Terminate


#### Syntax theme for the Atom.io editor

Terminate-syntax (this package) goes really well with Terminate-ui. Make sure to pair these together.

An adaptation of Apple’s green default Terminal settings with a touch of blues, yellows and red to contrast important syntax like function calls, constants, strings, operators and comments while keeping a central color scheme.

LESS (here is a screenshot of Terminate’s color scheme)

less #### CSS css #### HTML html #### Markdown markdown #### Javascript javascript #### Ruby ruby #### Python python #### Elixir elixir

Idea behind Terminate:

Color Scheme

Installation

> apm install terminate-syntax or search and install theme in Preferences -> Install -> Install Packages -> terminate-syntax

Language Support

Terminate should display nicely with most common languages. If not open an issue and I’ll fix it (I’m also open to pull-requests. See below for more information). I’ve tested Terminate with the following languages: - Markdown - HTML & CSS (LESS, SASS) - Python - Ruby - Javascript & JSON - Elixir

Pull Requests

Gladly accepting pull-requests. First open an issue if one hasn’t been opened already and let’s discuss changes. I’d like help to work with other languages that I am not familiar. Those would be any languages I have not supported above. Thank you!

Todo:

Keywords: syntax, theme, vim, macosx, mac, apple, ios, terminal, command-line Suggest keywords
Fork me on GitHub