Atom Packages Directory

a package directory for a text editor of the 21st Century

Linter Phpmd

Install with:
    apm install linter-phpmd
  

linter-phpmd

Build Status Dependency Status apm apm

This linter plugin for Linter provides an interface to phpmd. It will be used with files that have the “PHP” syntax or PHP embedded within HTML. A list of the rules checked and their definitions can be found here: http://phpmd.org/rules/index.html

Installation

### phpmd installation Before installing this plugin, you must ensure that phpmd is installed on your system. For detailed instructions see phpmd.org, the simplified steps are:

  1. Install php.
  2. Install Composer.
  3. Install phpmd by typing the following in a terminal: ShellSession composer global require phpmd/phpmd

After verifying that phpmd works from your terminal, proceed to install the linter-phpmd plugin.

Plugin installation

ShellSession $ apm install linter-phpmd

Keywords: lint, linter, phpmd, php Suggest keywords
Fork me on GitHub