Atom Packages Directory

a package directory for a text editor of the 21st Century

Linter Govet

Install with:
    apm install linter-govet


This linter plugin for Linter provides an interface to Go’s go vet. It will be used with files that have the Go syntax.


Linter package must be installed in order to use this plugin. If Linter is not installed, please follow the instructions here.

Plugin installation

$ apm install linter-govet


You must configure linter-govet by editing ~/.atom/config.cson (choose Open Your Config in Atom menu): 'linter-govet': 'executablePath': path to Go executable. Use `which go` to find it out.


If you would like to contribute enhancements or fixes, please do the following:

  1. Fork the plugin repository.
  2. Hack on a separate topic branch created from the latest master.
  3. Commit and push the topic branch.
  4. Make a pull request.
  5. welcome to the club

Please note that modifications should follow these coding guidelines:

Thank you for helping out!

Keywords: go, golang, linter Suggest keywords
Fork me on GitHub