Atom Packages Directory

a package directory for a text editor of the 21st Century

Dartlang

Install with:
    apm install dartlang
  

Dart plugin for Atom

A Dart plugin for Atom.

Build Status Join the chat at https://gitter.im/dart-atom/dartlang

Getting started

See our getting started guide! This is useful for users new to the plugin and users new to Atom as well.

Contributing!

The original developers are less active on this project; that said, contributions are welcome :) Please see our contributors guide.

For more actively maintained Dart tools, see the Dart plugin for IntelliJ, and DartCode, the Dart plugin for VSCode.

What is it?

This package is a lightweight, streamlined Dart development plugin for Atom. It supports features like auto-discovery of the Dart SDK, errors and warnings shown as you type, code completion, refactorings, debugging, and integration with Pub and other tools.

Dart plugin for Atom screenshot

Installing

Sending feedback

Please file feature requests and bugs at the issue tracker.

Get notified of news

Follow @dartpluginatom for news and announcements.

Terms and Privacy

The Dart plugin for Atom (the “Plugin”) is an open-source project, contributed to by Google. By using the Plugin, you consent to be bound by Google’s general Terms of Service and Google’s general Privacy Policy.

License

See the LICENSE file.

Keywords: dart, dartlang, flutter Suggest keywords
Fork me on GitHub