Atom Packages Directory

a package directory for a text editor of the 21st Century

Build Cssnext

Install with:
    apm install build-cssnext
  

build-cssnext

apm apm apm Travis David David

Atom Build provider for postcss-cssnext, compiles cssnext. Supports the linter package for error highlighting.

Installation

apm

Install build-cssnext from Atom’s Package Manager or the command-line equivalent:

$ apm install build-cssnext

Using Git

Change to your Atom packages directory:

```bash # Windows $ cd %USERPROFILE%.atom\packages

Linux & macOS

$ cd ~/.atom/packages/ ```

Clone repository as build-cssnext:

bash $ git clone https://github.com/idleberg/atom-build-cssnext build-cssnext

Inside the cloned directory, install Node dependencies:

bash $ yarn || npm install

Usage

Build

Before you can build, select an active target with your preferred build option.

Available targets:

Since output and input format are the same, it’s recommended to pick a name (or location) for your output files. This can be specified in your config.cson, all standard replacements can be used:

cson "build-cssnext": outputFile: "dist/{FILE_ACTIVE_NAME}"

Shortcuts

Here’s a reminder of the default shortcuts you can use with this package:

Select active target

Cmd+Alt+T or F7

Build script

Cmd+Alt+B or F9

Jump to error

Cmd+Alt+G or F4

Toggle build panel

Cmd+Alt+V or F8

License

This work is licensed under the The MIT License.

You are welcome support this project using Flattr or Bitcoin 17CXJuPsmhuTzFV2k4RKYwpEHVjskJktRd

Keywords: buildprovider, compile, cssnext, postcss, postcss-cssnext, linter, lint Suggest keywords
Fork me on GitHub