Atom Packages Directory

a package directory for a text editor of the 21st Century

Autocomplete Js Import by Daniel Garcia-Carrillo

Install with:
    apm install autocomplete-js-import
  

autocomplete-js-import

Autocomplete+ provider for JS import statements

Autocompletes ES6 or CommonJS (node) style import statements with relative file matching, full project fuzzy file matching or packages found in package.json.

By default, plugin will only allow autocompletion in the form of relative paths:

import local files screenshot

New Fuzzy matching (disabled by default)

Additional features

TODO / Known Issues

Keywords: autocomplete, autocomplete-plus, fuzzy, atom, es6, es2015, require, import Suggest keywords
Fork me on GitHub